You are not logged in.    Login    New User    Forum Home    Search  RSS Feed 

Location:
James' Games Site  \  Meteor 1  \  Bugs (v1.2 and above)  \  Startup Problems

Back to Threads

Viewing Thread: Startup Problems

 

d34db34t

Joined: 25 March 2004
Posts: 145
25 March 2004 03:31 (UK time)

When I launch the game, I get an error message saying "This program has perfomed an illegal operation..." why is this happening? I know this has something to do with the file ALLEG40.DLL.

Edited: 26 March 2004 23:15


You need to login to create posts in this thread.

James Bunting
Joined: 17 September 2003
Posts: 1302
28 March 2004 13:46 (UK time)

I have heard of other cases of this and I currently have no idea. You could try looking at this thread and try some of the advice there.

http://www.jbserver.com/forums/ThreadView.asp?ForumId=1&TopicId=18&ThreadId=103

I have also uploaded the Allegro DLL which you could try replacing...
ftp://ftp.jbserver.com/pub/jbgames/meteor/dlls/alleg40.dll

If none of this works then try adding -LogMessages to the command line (just like -skipintro) and take a look at the "MessageLog DATE.txt" log file.

You need to login to create posts in this thread.

Josh
Joined: 28 March 2004
Posts: 1
28 March 2004 20:43 (UK time)

I have had the same problem, and I tried what James listed. But it didn't work. On the error message that came up, this is what it say's in the details section of it;

METEOR caused an invalid page fault in
module ALLEG40.DLL at 0167:1005948e.
Registers:
EAX=00000000 CS=0167 EIP=1005948e EFLGS=00010246
EBX=06700000 SS=016f ESP=0680fab4 EBP=0680fab8
ECX=00000000 DS=016f ESI=81674c72 FS=1287
EDX=1009d7d0 ES=016f EDI=06b40ede GS=0000
Bytes at CS:EIP:
8b 51 08 ff 52 14 83 c4 04 5d c3 cc cc cc cc cc
Stack dump:
00000000 0680fac8 0045740c 00000000 c16a9f60 0680fae0 0044116d 0044dd70 00000000 0680fae4 0044de6e 0680faf0 0040101a ffffffff 0680fb00 0680fb84

Does this say anything of what the answer to this problem is?

You need to login to create posts in this thread.

d34db34t

Joined: 25 March 2004
Posts: 145
08 May 2004 05:31 (UK time)

Iv'e tried copying the ALLEG40.DLL file from Meteor 1.1.3, that didn't work.




The computer i'm using is a Pentium 2. I also have a Pentium 4, the game works on the P4 but not the P2

You need to login to create posts in this thread.

Mod_Maker

Joined: 05 July 2004
Posts: 85
14 July 2004 15:26 (UK time)

I am working on a mod and when i shall start the program
it are working all fine ,but when its begins reading
files it just turn it self off, whay?

You need to login to create posts in this thread.

Mod_Maker

Joined: 05 July 2004
Posts: 85
31 July 2004 15:23 (UK time)

Pleaaaaaaase!! Somebody help me!!!




You need to login to create posts in this thread.

James Bunting
Joined: 17 September 2003
Posts: 1302
01 August 2004 21:39 (UK time)

Yes this one is a known bug, it should be fixed in v1.21 (well hopefully) which will be out any day now.

You need to login to create posts in this thread.

James Bunting
Joined: 17 September 2003
Posts: 1302
01 August 2004 21:39 (UK time)

Yes this one is a known bug, it should be fixed in v1.21 (well hopefully) which will be out any day now.

You need to login to create posts in this thread.

Mod_Maker

Joined: 05 July 2004
Posts: 85
03 August 2004 17:51 (UK time)

I hope so.



You need to login to create posts in this thread.

James Bunting
Joined: 17 September 2003
Posts: 1302
03 August 2004 23:40 (UK time)

We got this mod to work off-line.

For info of readers:

This problem was caused by a modded weapon file, the game was crashing to the desktop while loading the game data.

I am still unsure as to exact cause but I think that it has something to do with weapons in the mod folder using data (sprites etc) from the original base. Normally this works OK and is considered as good practice (unless you want a new sprite for the weapon). 99% of modded weapons don't have this problem, I am trying to nail the exact cause, any info from other modders would be helpful.

You need to login to create posts in this thread.

Dave Man

Joined: 19 October 2003
Posts: 374
04 August 2004 14:29 (UK time)

I seem to have the same problem but it has to do with my race files, I made a bunch of races for my new mod and when I tried to load the mod after I was done it crashed before it loaded, when I deleted the race files it loaded correctly. I can send you a copy of the race files if you want to look at them.

You need to login to create posts in this thread.

d34db34t

Joined: 25 March 2004
Posts: 145
07 December 2004 00:54 (UK time)

Try upgrading to Allegro 4.1.13.0

i have played another game that uses 4.1.13.0 (alleg41.dll)- the game that uses it (NiM 2- download it from www.zaphire.ca) works fine on my machine

anyway back to M1

i can run Meteor 1.1.3 or lower just fine on my machine, but why not 1.2/1.2.1

You need to login to create posts in this thread.

d34db34t

Joined: 25 March 2004
Posts: 145
08 December 2004 03:59 (UK time)

Pleeeeeeeeeeeeeeeeeeeeease!!

SOMEONE HELP ME FIND THE CAUSE OF THIS ERROR!!!!!!!!!!!

You need to login to create posts in this thread.

Assain

Joined: 02 November 2003
Posts: 979
08 December 2004 21:25 (UK time)

Why would you want to run 1.3.3 o or lower? Its an older version of 1.2. The only thingy thats really different is that 1.3.3 doesnt include conveyor tiles, the last two maps of Meteor, and some of the bug fixes (thats why 1.2 prolly works).

You need to login to create posts in this thread.

Dave Man

Joined: 19 October 2003
Posts: 374
10 December 2004 20:18 (UK time)

Not to be rude Assain, but Busted said he couldn't run version 1.2 on his machine and only 1.13 or lower versions of meteor worked.

You need to login to create posts in this thread.

Assain

Joined: 02 November 2003
Posts: 979
12 December 2004 23:07 (UK time)

:p ya srry i missed that ^_^

You need to login to create posts in this thread.

James Bunting
Joined: 17 September 2003
Posts: 1302
14 December 2004 00:55 (UK time)

Meteor v1.2 has considerable changes, serverval core areas of the code were rewritten and its 16 bit colour.

Try running Meteor.exe -LogMessages (modify a new shortcut and add " -LogMessages" (no quotes) to the command line.

Then send me the MessageLog 2004-??-??.txt file that it made in the Meteor folder.

You need to login to create posts in this thread.

d34db34t

Joined: 25 March 2004
Posts: 145
14 January 2005 00:32 (UK time)

the log messages say

example (one on dec. 12 04)

2004-12-12 ************************
2004-12-12 * Starting Meteor ******
2004-12-12 ************************

or something like that

You need to login to create posts in this thread.

d34db34t

Joined: 25 March 2004
Posts: 145
14 January 2005 00:35 (UK time)

games like Half life, quake 2 & age of empires 2 (just to name a few) work fine on my machine, but not Meteor v1.2/1.2.1 or Meteor II

You need to login to create posts in this thread.



Forums system (C) 1999, 2017 by James Bunting.

Terms of Use